Frustrating USB stack issue

JesseVoss 发表于 06-12 368 次查看


Here's the situation. All my devices used to work in harmony, until a few days ago. That was when I turned on my printer, which I hadn't used for months. Instead of it being recognised by Windows as usual, I got "Device Failed to Connect". I got the Windows sound titled "Device Failed to Connect", the device can't be used. Tried it a bunch more times, wouldn't work. Amusingly (but only for a short while) the printer (a Canon Pixma MP280, it's a multifunctional actually) works without a flaw in both of my virtual machines. I wanted to scan a document: couldn't in Windows 7 (host OS), could do so no problem in Ubuntu (guest OS). Similarly, the printer gets detected and installed just fine in a guest Win8.1.Googling around, one suggestion I found was to uninstall all USB controllers and let Windows redetect them. I did so. This was a bad call: not only did my printer not return to the realm of detected, functioning, devices, now my UMTS stick won't work either. As with the printer, I can use it just fine inside a VM, but not on the host OS.This is especially frustrating since I've searched high and low for all the places where driver files might hide, in an effort to remove them and restore the system to a pre-bogus-device not detected state, to no avail. Needless to say, I've tried first updating then removing and reinstalling the drivers in question. I've removed the devices' .sys files from %SystemRoot%\System32\drivers, and I've used pnputil.exe to remove the not recognised devices' drivers from Windows' driver store. Made no difference whatsoever, same as before. Note, however, I have not yet gone deleting .inf and .cat files.Oh, also, I try to install the devices' drivers manually, by pointing them at the .inf files I know are theirs, and Windows doesn't detect any valid drivers in that folder.I would like to look at the exact sequence of events that occurs when I plug in my device and get the "Device Failed to Connect" sound, and I would like to find the cause of this behaviour and fix it. How might I do that? I have Windows Internals open as I type this, and I also have this neat little utility called SysTracer that I use to take a snapshot of a clean VM before and after driver installation. These efforts, however, are slow-going. Tips would be appreciated.

Please help

I didn't find the right solution from the internet.

Product Animation Service

Thank you

© 2005-2018, all rights reserved. 粤ICP备13011623号-1
IT课店 发现好课程